units: drop dependency on systemd-remount-fs.service from systemd-pstore.service
This dependency is now generated automatically given we use
StateDirectory=. Moreover the combination of Wants= and After= was too
strong anyway, as whether remount-fs is pulled in or not should not be up
to systemd-pstore.service, and in fact is part of the initial
transaction anyway.
core: automatically add dependency on systemd-remount-fs.service if StateDirectory= is used
And similar for other settings that require a writable /var/.
Rationale: if these options are used for early-boot services (such as
systemd-pstore.service) we need /var/ writable. And if /var/ is on the
root fs, then systemd-remount-fs.service is the service that ensures
that /var/ is writable.
This allows us to remove explicit deps in services such as
systemd-pstore.service.
pid1: by default make user units inherit their umask from the user manager
This patch changes the way user managers set the default umask for the units it
manages.
Indeed one can expect that if user manager's umask is redefined through PAM
(via /etc/login.defs or pam_umask), all its children including the units it
spawns have their umask set to the new value.
Hence make user units inherit their umask value from their parent instead of
the hard coded value 0022 but allow them to override this value via their unit
file.
Note that reexecuting managers with 'systemctl daemon-reexec' after changing
UMask= has no effect. To take effect managers need to be restarted with
'systemct restart' instead. This behavior was already present before this
patch.
Michael Biebl [Sun, 5 Jul 2020 09:44:39 +0000 (10:44 +0100)]
systemd (245.6-2) unstable; urgency=medium
[ Dan Streetman ]
* 40-vm-hotadd.rules: check offline before onlining memory/cpus.
The kernel will return EINVAL if the memory or cpu is already online,
which is harmless, but adds a confusing error to the log. Avoid the error
message by only onlining if the memory or cpu is currently offline.
(LP: #1876018)
[ Michael Biebl ]
* d/t/boot-and-services: use canonical name for NetworkManager service
* Fix build with libmicrohttpd 0.9.71.
The return type of callbacks was changed from int to an enum.
[ Balint Reczey ]
* dhclient-exit-hooks.d/timesyncd: Act only when systemd-timesyncd is available.
Otherwise the hook script might trigger an error if the
systemd-timesyncd package is uninstalled but not purged. (LP: #1873031)